Folder AVG Forums » Archive » Archive » AVG Free » AVG for Linux » Bug - Scan Of File Is Not Finishing
January 15, 2013 09:12 Bug - Scan Of File Is Not Finishing #222987
Top
masuch

Avatar

Novice
Join Date: 27.5.2012
Posts: 3
Hi,

I am running each day from cron command:

/usr/bin/avgscan -a -H -c -w --exclude /var/backtrack/sources --exclude /media --exclude /cdrom --exclude /mnt --exclude /opt/metasploit-4.4.0 --exclude /var/mail --exclude /var/spool/postfix /"  # /sys /proc are not included by default ; always stuck on /var/backtrack/sources

but each day it stuck on one file, scanning it repeatedly without continuing to the next file or finish the process.
I had/have to always kill it in the morning by command

kill -9 PID

Today it was file: ubuntu.ico - which is file created by me - it is really only icon file. I could not attached the file because it is forbidden.

log is reporting scanning file repeatedly without ending:
[~100.0%] /ubuntu.ico
[~100.0%] /ubuntu.ico
[~100.0%] /ubuntu.ico
[~100.0%] /ubuntu.ico
[~100.0%] /ubuntu.ico
[~100.0%] /ubuntu.ico
...
...
...

Yesterday it was:
[~100.0%] /var/backtrack/sources/traceroute/2.0.13/bt2/upstream-sources/trac...
[~100.0%] /var/backtrack/sources/traceroute/2.0.13/bt2/upstream-sources/trac...
[~100.0%] /var/backtrack/sources/traceroute/2.0.13/bt2/upstream-sources/trac...
[~100.0%] /var/backtrack/sources/traceroute/2.0.13/bt2/upstream-sources/trac...
[~100.0%] /var/backtrack/sources/traceroute/2.0.13/bt2/upstream-sources/trac...
...
...


So , As you can noticed I have been always excluded that specific file/directory in command line but I am afraid that it is bug which should be corrected.

apt-cache policy avg2012flx

avg2012flx:
Installed: 2012.1795
Candidate: 2012.1795
Version table:
*** 2012.1795 0
100 /var/lib/dpkg/status

lsb_release -rd

Description: Ubuntu 12.10
Release: 12.10

kind regards,
Martin
January 15, 2013 12:11 Re: Bug - Scan Of File Is Not Finishing #222999
Top
Rigby

Avatar

Novice
Join Date: 25.8.2009
Posts: 94
Hi,

Thanks for your report, we are not able to reproduce your problem, please attach logs from /opt/avg/av/log/, mentioned file ubuntu.ico and core dump of avgscand if possible (kill -11 <pid>).

Thanks a lot!

R.

Note: There is new version AVG2013: http://free.avg.com/us-en/download.prd-alf.tpl-stdfull You can try to upgrade maybe it helps.