Folder AVG Forums » Archive » Archive » AVG Free » AVG 2012 Free Edition » AVG Installation/Uninstallation » Installation Error - MSI Action Failed
October 13, 2011 07:50 Installation Error - MSI Action Failed #176492
Reply with Quote | Quick Reply | Top
auchengyu

Avatar

Novice
Join Date: 13.10.2011
Posts: 5
dear AVG.

I keep getting the same error others also get:

Error code: OxC0070643
Error message: General internal error
Additional message: MSI Engine: Failed to install the product.
@ AVG MSI_Error 27046
Driver installation failed (0xE0010057)
Context: AVG product installation, MSI action failed


I have tried installing from AVG9 to AVG 2012. But it failed in many ways. Things I have tried already:

1. Followed instructions on: http://forums.avg.com/ww-en/avg-forums?sec=thread&act=show&id=171231 and used removal tool (attached removal log) and deleted those AVG folders if they existed and tried installing 2012 full installation (already downloaded) but still the same error.

2. Also tried to install AVG 9 again (which works) then did an uninstall AVG9, afterwards also the removal tool but I keep getting the same error.

Dont know what I can do anymore... need your help~~..
attached the 2 files. Thanks in advance!
October 13, 2011 08:05 Re: Installation Error - MSI Action Failed #176497
Reply with Quote | Quick Reply | Top
will_h

Avatar

Moderator
Join Date: 2.8.2010
Posts: 1891
Hello auchengyu,

Please provide us with MSinfo32 output:
- Click on the "Start" button.
- Choose the "Run" option.
- Please type the "msinfo32" (without quotes) command to the command line and confirm by clicking on the "OK" button (or press Enter).
- After the tool is launched, please choose the "File" menu and the "Save..." option.
- Choose a name.

Please pack the output in an archive (zip file) and provide us with it.

Thank you

___________________AVG TeamHow-To articles | FAQ | Free Support
October 13, 2011 08:21 Re: Installation Error - MSI Action Failed #176499
Reply with Quote | Quick Reply | Top
auchengyu

Avatar

Novice
Join Date: 13.10.2011
Posts: 5
MSinfo 32..

hi. here is the MSinfo zipped as requested.
thanks in advance!
October 13, 2011 11:35 Re: Installation Error - MSI Action Failed #176527
Reply with Quote | Quick Reply | Top
will_h

Avatar

Moderator
Join Date: 2.8.2010
Posts: 1891
Hi auchengyu,

Please uninstall Lavasoft Adware. And there is some suspicious file 'hir3c.tmp' in users temp directory.
and some ggsafe sys/service.



___________________AVG TeamHow-To articles | FAQ | Free Support
October 13, 2011 13:01 Re: Installation Error - MSI Action Failed #176539
Reply with Quote | Quick Reply | Top
auchengyu

Avatar

Novice
Join Date: 13.10.2011
Posts: 5
hi will__h,

I have uninstalled Lavasoft.
And also uninstalled the GG safe (that was for online gaming protection)

Couldnt find hir3c.tmp though.

After reboot I tried installing AVG 2012 again,but I still get the same error.....

Any more help or advise? >.< getting frustated....
October 13, 2011 15:05 Re: Installation Error - MSI Action Failed #176552
Reply with Quote | Quick Reply | Top
will_h

Avatar

Moderator
Join Date: 2.8.2010
Posts: 1891
Hi auchengyu,

please provide us with GMER scan results to better analyze your situation.

Thank you


___________________AVG TeamHow-To articles | FAQ | Free Support
October 14, 2011 03:29 Re: Installation Error - MSI Action Failed #176658
Reply with Quote | Quick Reply | Top
auchengyu

Avatar

Novice
Join Date: 13.10.2011
Posts: 5
hi will__h,

below are the 2 scan results.
thnx

October 14, 2011 04:26 Re: Installation Error - MSI Action Failed #176663
Reply with Quote | Quick Reply | Top
auchengyu

Avatar

Novice
Join Date: 13.10.2011
Posts: 5
another problem..

hi Will,

Ok, for the GMER scan (the full root scan), I let the laptop on overnight for the scan took more than hours.

When I woke up I posted you the results.
but now I have another problem: my sound becomes choppy everytime the pc is running something, for example; opening Internet explorer. could you pls tell me how to fix this choppy thing? it seems the pc is running very slowly when I open things, together with the choppy sound... pls help >.<....


UPDATE: ok I managed to fix choppy sound thing via this: http://blogcritics.org/scitech/article/fixing-choppy-audiovideo-playback/


I have AVG 9 for now. do you see any problems in those logs? cheers
October 17, 2011 08:37 Re: Installation Error - MSI Action Failed #177185
Reply with Quote | Quick Reply | Top
Pokornyz

Avatar

Administrator
Join Date: 29.11.2010
Posts: 8235
Hello auchengyu,

From provided results it looks like your computer is infected.

For help on this unpleased situation please scan your computer using updated AVG Rescue CD.

Thank you
___________________AVG TeamHow-To articles | FAQ | Free Support