Folder AVG Forums » AVG 2014 » AVG 2014 » Internet and Network » [SOLVED] Network Drives - AVG 2014 & 2013 Blocking UDP Ports 137 & 138
Page 1 of 2 12››
September 25, 2013 00:49 [SOLVED] Network Drives - AVG 2014 & 2013 Blocking UDP Ports 137 & 138 #234149
Reply with Quote | Quick Reply | Top
sa2012

Avatar

Novice
Join Date: 13.1.2012
Posts: 16
I have been using AVG Internet Security Paid-For products for a number of years with no real issues.

On Sunday AVG Internet Security 2013 and today AVG Internet Security 2014 on a different windows computer stopped connections to all mapped network drives.

The AVG firewall log shows that UDP ports 137 and 138 were being blocked even though File and Print Sharing is enabled within AVG

I already sent in the diagnostics gathered by the AVG Diagnostic tool for the problem that happened on AVG Internet Security 2013 (Ticket AVG#0008023635 )

Today's problem needed a number of reboots before it cleared itself.

I thought at some point that the AVG Software enters a defensive state blocking file sharing after an update that requires a reboot. But then the problem persisted even after the reboot and needed several reboots before it went away.

The two incidents both happened on Windows 7. This has not been seen on Windows XP Pro.

Today's problem info:

Windows 7 Professional 64-bit
AVG 2014.0.4117
AVG DB 3604/6696 [24 September 2013 19:58]
No other AV software installed
Macfee Security Central was pre-installed but I removed it before the problem arose

The AVG 2013 installation (A Desktop PC with Windows 7 Ultimate 64-bit) did not have any other AV software now or before.

The problem was confirmed as being AVG as disabling the Firewall allowed access to the network drives,

I have more screenshots of the log file but appear to be restricted to 3 attachments - if needed I can zip and attach

PS: Why is it not possible to export the firewall log ? Have not found a way other than taking screenshots
AVG2014 FW F&P Setting.pngAVG2014 FW Log-1.pngAVG2014 FW Log-2.png
September 25, 2013 14:58 Re: Network Drives - AVG 2014 & 2013 Blocking UDP Ports 137 & 138 #234173
Reply with Quote | Quick Reply | Top
_malchys_

Avatar

Administrator
Join Date: 2.5.2012
Posts: 1875
Hi sa2012,

I'd recommend whitelisting IP address of the device which is sharing mentioned folders. Are mentioned folders shared from computer (which OS) or from NAS or something else?

Thanks.



AVG Team
How-To articles | FAQ | Free Support
September 25, 2013 21:18 Re: Network Drives - AVG 2014 & 2013 Blocking UDP Ports 137 & 138 #234182
Reply with Quote | Quick Reply | Top
sa2012

Avatar

Novice
Join Date: 13.1.2012
Posts: 16
_malchys_ wrote
Hi sa2012,

I'd recommend whitelisting IP address of the device which is sharing mentioned folders. Are mentioned folders shared from computer (which OS) or from NAS or something else?

Thanks.




Hi. Thanks for the reply.

The shares are on a Windows 2012 R2 Server and a QNAP NAS.

I had a reply from AVG in relation to the AVG 2013 failure and they asked me to add the local network subnet in the Defined Networks section of the AVG Firewall setting - which is similar to what you are saying so I have added 192.168.0.0 to 192.168.0.255

But why is it necessary as in AVG Internet Security 2014 Firewall Settings have Local Network appearing as an IPV6 long number followed by comma and 192.168.0.0-

Will now have to wait a few days to see if the problem has been fixed by adding the network subnet
September 26, 2013 13:10 Re: Network Drives - AVG 2014 & 2013 Blocking UDP Ports 137 & 138 #234206
Reply with Quote | Quick Reply | Top
_malchys_

Avatar

Administrator
Join Date: 2.5.2012
Posts: 1875
Hi sa2012,

Local sites are appearing in both, IPV4 and IPV6 formats if it's supported by the operating system (Windows Vista and higher). Values you are seeing are not complete... move your cursor next to the drop down arrow and resize field to display all local addresses.

Please let me know what's the status after some testing.

Thanks.



AVG Team
How-To articles | FAQ | Free Support
September 26, 2013 16:55 Re: Network Drives - AVG 2014 & 2013 Blocking UDP Ports 137 & 138 #234219
Reply with Quote | Quick Reply | Top
sa2012

Avatar

Novice
Join Date: 13.1.2012
Posts: 16
Thanks for the advice on the incomplete info. It was fiddly to find where to find the right cursor to resize the Defined Networks window to see all the figures.

On the AVG2014 installation the problem came back just when Windows 7 came into life from Hibernation ! I noticed File & Print Sharing is showing as Disabled now. I did not disable it. So it must have got disabled on coming off hibernation - but this cannot be the only problem since the other system with AVG 2013 is set not to go to sleep. So this suggests that there are 2 problems leading to the same symptom. Also I notice on AVG2013 Firewall File & Print settings page there is more detail listing all routers I ever used and their MAC Addresses and if enabled or not. I cannot see this detail on AVG2014

The time of the block on port 137 in the log coincides exactly with the time I resumed windows from hibernation.

AVG2014 FW Block_2013-09-26.pngavg2014 FW Defined Networks.png
September 26, 2013 17:10 Re: Network Drives - AVG 2014 & 2013 Blocking UDP Ports 137 & 138 #234220
Reply with Quote | Quick Reply | Top
sa2012

Avatar

Novice
Join Date: 13.1.2012
Posts: 16
OK more info. We are getting somewhere.

It appears that on this system at this moment in time AVG2014 is stuck trying to identify the router and network - and whilst doing this and it has been doing it since resuming from hibernation almost an hour ago - it has disabled File and Print Sharing !!!!!

Well Done AVG

Note that this has only been seen on Windows 7 and not on XP Pro.

See screenshot
AVG2014 FW stuck on identifying Router.png
October 7, 2013 13:13 Re: Network Drives - AVG 2014 & 2013 Blocking UDP Ports 137 & 138 #234787
Reply with Quote | Quick Reply | Top
Pokornyz

Avatar

Administrator
Join Date: 29.11.2010
Posts: 8245
Hello sa2012,

Note that this has only been seen on Windows 7 and not on XP Pro.

Because it doesn't seem to be an AVG issue but Windows in Windows 7. We use windows profiles so sharing etc is allowed according to chosen profile. In your case it seems windows didn't assign profile.

Thank you



AVG Team
How-To articles | FAQ | Free Support
October 8, 2013 02:30 Re: Network Drives - AVG 2014 & 2013 Blocking UDP Ports 137 & 138 #234819
Reply with Quote | Quick Reply | Top
anthodhalia

Avatar

Novice
Join Date: 8.7.2013
Posts: 11
My Query..

Are they suitable for any version? Please produce some more attachments for the more detailed view. Thanks for sharing the info in detail.
October 8, 2013 10:29 Re: Network Drives - AVG 2014 & 2013 Blocking UDP Ports 137 & 138 #234836
Reply with Quote | Quick Reply | Top
sa2012

Avatar

Novice
Join Date: 13.1.2012
Posts: 16
Pokornyz wrote
Hello sa2012,

Note that this has only been seen on Windows 7 and not on XP Pro.

Because it doesn't seem to be an AVG issue but Windows in Windows 7. We use windows profiles so sharing etc is allowed according to chosen profile. In your case it seems windows didn't assign profile.

Thank you




Thanks for the feedback

So how do i troubleshoot that? what do i look into to understand why windows had a problem? It does not always happen.

From the AVG firewall settings screen it looked as if it was waiting to establish which router the network was going through. Because when is to ok the router name is displayed in the File and Printer Sharing Firewall setting:

"You are now connected to the network SAWnr2000."

Whereas when it was stuck it said:

"You are now connected to the network identifying ...."
October 19, 2013 00:31 Re: Network Drives - AVG 2014 & 2013 Blocking UDP Ports 137 & 138 #235428
Reply with Quote | Quick Reply | Top
sa2012

Avatar

Novice
Join Date: 13.1.2012
Posts: 16
Problem still happening. No responses from AVG Support.
Sent new diagnostics using the AVG Diag Collection tool.

New evidence is that when attempting today to manually re-enable the File and Print sharing within the AVG 2014 Firewall the following error message was returned:

An error occurred when saving the configuration: specified file was not found

New diagnostics collected and sent to AVG

Edit:
Disabling AVG 2014 including firewall and re-enabling it all clears the problem !!!
AVG 2014 F&P Disabled Error unable to find file_2013-10-19.pngAVG 2014 FW Block 2013-10-19.png
Page 1 of 2 12››